demagnetized rotor?

Information relating to the Matchless G2 or AJS Model 14 250cc Lightweight
itma
Posts: 7725
Joined: Tue Nov 22, 2005 6:01 pm
Location: UK

demagnetized rotor?

Post by itma »

I would have replaced the wipac rotor with a lucas one to match the stator.

gap between stator and rotor is only about 4-6thou if I remember right.Edited by - itma on 05 Apr 2011 5:32:01 PM
Eric
Deceased
Posts: 1221
Joined: Fri Jan 01, 1993 12:00 am
Location: WEST MIDLANDS UK

demagnetized rotor?

Post by Eric »

Ian please don't forget to let us know what you decided to do about your problem? That's how we all learn.
Ian 14 G2
Posts: 45
Joined: Thu Dec 24, 2009 4:53 pm
Location: TYNE AND WEAR UK

demagnetized rotor?

Post by Ian 14 G2 »

Well everything is now working perfectly, a new regulator/rectifier from Mr Goff and everthing is up and running. So my switch and old alternator have been my problem,I gave the light switch a test with my multimeter and found it worked when it felt like it so I took the advice posted from Groily ( top bloke) and got a new regulator/rectifier and read the article about 6v to 12v lightweight conversion posted on the site and thats it up and working.I've tried my old wipac alternator and still got a discharge so I know thats been at fault to. Many thanks to all who have replied to my question.
Groily
Member
Posts: 1427
Joined: Thu Jul 04, 2002 1:00 am
Location: NORMANDIE FRANCE

demagnetized rotor?

Post by Groily »

Well that's really good to hear Ian, and I'll get (yet) another glass of something so I can celebrate on your behalf!
spindle
Posts: 251
Joined: Fri Apr 02, 2010 9:52 am
Location: sussex UK

demagnetized rotor?

Post by spindle »

Post Reply